PS3 Media Server (SubJunk Build) 1.21.0-SB19

This is a bugfix release.
Thanks to Mads for QA on this release

Download:


Changelog: (full version)

SVN:
http://www.spirton.com/svn/PS3MS-SB

35 Comments

  1. Thanks for the build SB19, downloading now will test and update

  2. Hello, thank you for all your hard work.
    I get data type not supported on some files. Here is a relevant portion of the debug.log file:
    [mencoder] INFO 23:07:16.855 Starting mencoder -ss 0 -quiet /media/Backup/Movies/Corssing the Event Horizon – Rise to the Equation, a Symposium with scientist Nassim Haramein/1.1 Crossing the Event Horizon – Interview with Dr. Elizabeth Raucher.mkv -quiet -quiet -oac lavc -of mpeg -quiet -quiet -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -lavdopts debug=0:threads=4 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=256:threads=4:keyint=0:vqscale=0:vqmin=0 -spuaa 3 -quiet -quiet -subdelay 20000 -quiet -quiet -ofps 30000/1001 -quiet -quiet -quiet -mc 0 -af lavcresample=48000 -srate 48000 -o /tmp/ps3mediaserver/mencoder1299301636804
    [mencoder] INFO 23:07:16.861 Reading pipe: /tmp/ps3mediaserver/mencoder1299301636804
    [mencoder] DEBUG 23:07:16.861 Opening file /tmp/ps3mediaserver/mencoder1299301636804 for reading…
    [Thread-223] DEBUG 23:07:16.877 The vqmin option must be >= 1: 0
    [Thread-223] DEBUG 23:07:16.877 Error parsing option on the command line: -lavcopts

  3. dude youre fast, i’ll give you some feedback in a moment.

  4. The installer gave an error on an attempt to write to the MediaInfo.dll. I chose ignore and it whent on. (win7 x64)

  5. Bravia W5500 Owner

    March 6, 2011 at 7:26 am

    Thanks!

    I’ve noticed that i get off-sync sound with more files.. if i forward/rewind the movie, then it works again.

    Nomad: That’s normal.. probably because mediainfo is locked somehow.. try uninstall – restart, then install new version.

  6. Bravia W5500 Owner: I get more off-sync audio as well now. Happens with some of the latest Fact or Faked episodes (fact.or.faked.paranormal.files.s01e09.720p-dhd to be specific).
    Also I am unable to restart the HTTP server from my PS3 XMB with a message saying: Media Server Error: A network error has occurred. (00000000)

  7. ok thnx BWO. Did not notice off sync sound, jet. If so i will report here.

  8. SubJunk

    March 6, 2011 at 2:05 pm

    @dl0gic: Which version of the program did this start happening with?

    @Nomad: That usually means you attempted to install it while the program was running

    @Bravia: Can you email me 2 debug logs; one from a version that synchronised properly, and one from this one?

    @Drugs: Which version of the program first produced the HTTP restart error?

  9. @Subjunk: I had to go all the way back to pms-setup-windows-1.10.51 stable for it to work.
    I tried pms-setup-windows-1.20.412 and Subjunk SB1, SB18 and SB19 but none of them worked.
    With all the versions after 1.10.51.1 I get stuck at this message in the trace tab when I try to restart HTTP server:
    [New I/O server worker #1-2] TRACE 04:25:31.939 Sending BYEBYE…

  10. Don’t know if it’s worth noting but javaw.exe*32 won’t shut down after the error and has to be closed manually in Windows Task Manager. I’m running JRE 6 Update 24.

  11. SubJunk

    March 6, 2011 at 5:30 pm

    @Drugs: That makes sense since I didn’t even know that option existed; it was made and broken before I was developing for this program 🙂

  12. First off thanks for keeping this project going. Just upgraded to this bundle from bundle 18. But now I’m unable to browse my media share. Get a DNLA 2006 error. Also noticed that it says the PS3 isn’t found but I have the ps3 media icon on my xmb. Last bit of my trace log shows:

    [main] TRACE 16:05:42.062 java.lang.ArrayIndexOutOfBoundsException: 8
    [main] TRACE 16:05:42.063 at net.pms.newgui.NetworkTab.addPlugins(NetworkTab.java:325)
    [main] TRACE 16:05:42.064 at net.pms.newgui.LooksFrame.serverReady(LooksFrame.java:440)
    [main] TRACE 16:05:42.064 at net.pms.PMS.init(PMS.java:533)
    [main] TRACE 16:05:42.065 at net.pms.PMS.get(PMS.java:1393)
    [main] TRACE 16:05:42.065 at net.pms.PMS.main(PMS.java:1462)

  13. Ok a clean re install fixed my previous issue, please ignore 🙂

  14. Thanks for the new version 🙂
    In this version like as all works normally.
    Thanks for the good program for PS3 😉

  15. SubJunk

    March 10, 2011 at 10:06 am

    @Sveller: Thanks! That makes my day 🙂

  16. hi SubJunk, thanks for your hard work. using the new SB19 and still have some issues:
    [Thread-947] TRACE 17:54:55.906 Starting transcode/remux of Animal Kingdom (2010) 720p BDRip AC3 x264 – AdiT.mkv
    [win32/tsMuxeR.exe] TRACE 17:54:57.687 Process D:\Alternative PSM\PS3 Media Server\win32\tsMuxeR.exe has a return code of -2! Maybe an error occurred… check the log file
    [Thread-978] TRACE 17:55:01.672 Starting transcode/remux of Animal Kingdom (2010) 720p BDRip AC3 x264 – AdiT.mkv
    [Thread-979] TRACE 17:55:12.734 FATAL ERROR: OutOfMemory / dumping stats
    [Thread-979] TRACE 17:55:12.734 Not enough memory to allocate 419430400 bytes… Using half of it
    [Thread-1653] TRACE 19:38:36.402 Starting transcode/remux of Blizkiy.vrag.2010.x264.BDRip.720p.mkv
    [Thread-1653] TRACE 19:38:37.246 The video will not play or show a black screen on the ps3…
    [Thread-1686] TRACE 19:38:55.621 Starting transcode/remux of Blizkiy.vrag.2010.x264.BDRip.720p.mkv
    [win32/mencoder.exe] TRACE 19:39:26.371 Process D:\Alternative PSM\PS3 Media Server\win32\mencoder.exe has a return code of 1! Maybe an error occurred… check the log file
    [Thread-1704] TRACE 19:39:26.434 Exception in thread “Thread-1704” java.lang.ArrayIndexOutOfBoundsException
    [Thread-1704] TRACE 19:39:26.434 at java.lang.System.arraycopy(Native Method)
    [Thread-1704] TRACE 19:39:26.434 at net.pms.io.BufferedOutputFile.read(BufferedOutputFile.java:642)
    [Thread-1704] TRACE 19:39:26.434 at net.pms.io.BufferedOutputFile.access$100(BufferedOutputFile.java:31)
    [Thread-1704] TRACE 19:39:26.824 at net.pms.io.BufferedOutputFile$WaitBufferedInputStream.read(BufferedOutputFile.java:57)
    [Thread-1704] TRACE 19:39:26.824 at net.pms.io.BufferedOutputFile$WaitBufferedInputStream.read(BufferedOutputFile.java:66)
    [Thread-1704] TRACE 19:39:26.824 at net.pms.network.Request.sendBytes(Request.java:539)
    [Thread-1704] TRACE 19:39:26.824 at net.pms.network.Request.answer(Request.java:500)
    [Thread-1704] TRACE 19:39:26.824 at net.pms.network.RequestHandler.run(RequestHandler.java:162)
    [Thread-1704] TRACE 19:39:26.824 at java.lang.Thread.run(Unknown Source)
    [Thread-1709] TRACE 19:39:31.449 Starting transcode/remux of Blizkiy.vrag.2010.x264.BDRip.720p.mkv
    [Thread-1727] TRACE 19:39:50.825 Starting transcode/remux of Blizkiy.vrag.2010.x264.BDRip.720p.mkv
    [Thread-1727] TRACE 19:39:50.840 The video will not play or show a black screen on the ps3…
    [Thread-1760] TRACE 19:40:10.934 Starting transcode/remux of Blizkiy.vrag.2010.x264.BDRip.720p.mkv
    [Thread-1778] TRACE 19:40:32.825 FATAL ERROR: OutOfMemory / dumping stats
    [Thread-1778] TRACE 19:40:32.825 Not enough memory to allocate 419430400 bytes… Using half of it
    [Thread-1793] TRACE 19:41:07.435 Starting transcode/remux of Blizkiy.vrag.2010.x264.BDRip.720p.mkv
    [Thread-1805] TRACE 19:41:17.232 Starting transcode/remux of Blizkiy.vrag.2010.x264.BDRip.720p.mkv
    [Thread-1807] TRACE 19:41:43.326 FATAL ERROR: OutOfMemory / dumping stats
    [Thread-1807] TRACE 19:41:43.326 Not enough memory to allocate 419430400 bytes… Using half of it

    any thoughts? thanks

  17. SubJunk

    March 10, 2011 at 8:46 pm

    @stutunaru: Do any other versions work for you?
    P.S. I love AdiT releases, too! He is awesome

  18. Hello,

    Works fine, thank you for the good work !

  19. well, i cants say for sure but i think i didn see these fatal error in previous releases.
    oooo man, AdiTs’ encodes are just perfect. i use to watch only his. 🙂

  20. SubJunk

    March 11, 2011 at 3:51 pm

    @stutunaru: Can you try installing previous versions to check when it first appeared? They are all still available for download

  21. Out of the blue i have a error massage wich says “Could not find the main class: net.pms.PMS. Program will exit ”

    I’ll try a re install.

  22. That helped. Very strange because i did not change anything after the last install.

  23. Error in mediainfo parsing: For input string “7/6”

    Hi All,

    Does anyone know what the error might mean? Thanks

    Running Vista x64 hardwired 1GB

  24. SubJunk

    March 13, 2011 at 12:12 pm

    @Scott: Probably a weird/corrupt video.

  25. @Nomad

    I got the same error. Re install fixed it for me as well

  26. I always have a problem playing XviD files with external subtitles.
    After playing the file using mencoder or avisynth it skips a part and continues playing and after a minute or so it skips back to where it first skipped and continues normal playback.

    If I use no encoder it just runs perfect. But I want to use subtitles.
    I sometimes have this with x264 files as well. But with those I can just fast forward the part where it happens and all is good.

    But with XviD it will happen anyway, even if I fast forward the part where it happens.

    I hope you can take a look into this.

    Thanks.

  27. Hi, thanks for an awesome version of PS3 media server. It’s all working great for me on w5500 Bravia. Excellent to be able to benefit from the latest Mencoder without losing subtitle support from older versions, it’s just super.

    Also I have a question for you I’m afraid I couldn’t find the answer to with search. Is there any way to remove the web folders from being visible , i.e. web videos, pictures etc. I don’t want to confuse other users of the software (wife!) and don’t really need to use the web folders – would prefer cleaner interface even though amazingly Youtube does work on this release for me. I’ve tried deleting the web.conf folder found in AppData/ Roaming, and also tried editing it with # symbols as suggested from forum search results. But I can’t seem to turn them off. What am I missing please?! Do I need to restart the program? Or is it not possible to remove the web folders?
    Thanks.

    Cheers,
    James

  28. Thanks for this update! It solves a lot of issues I had (I am using Philipps BDP-7500 B2 and Freenas server).

    But I found today 2 files not playing.
    Here are the trace:
    [New I/O server worker #1-1] DEBUG 16:57:37.815 Received on socket: USER-AGENT: IPI/1.0 UPnP/1.0 DLNADOC/1.50
    [New I/O server worker #1-1] INFO 16:57:37.815 HTTP: get/0$0$6$3$4$3/Dexter.S05E02.FRENCH.720p.HDTV.x264-SSL.mkv / 0-1172029633
    [New I/O server worker #1-1] DEBUG 16:57:37.815 Searching for objectId: 0$0$6$3$4$3 with children option: false
    [New I/O server worker #1-1] DEBUG 16:57:37.816 Asked stream chunk [0-1172029633] timeseek: 0.0 of Dexter.S05E02.FRENCH.720p.HDTV.x264-SSL.mkv and player nul
    l
    [New I/O server worker #1-1] TRACE 16:57:37.817 java.lang.NullPointerException: value
    [New I/O server worker #1-1] TRACE 16:57:37.817 at org.jboss.netty.handler.codec.http.HttpCodecUtil.validateHeaderValue(HttpCodecUtil.java:102)
    [New I/O server worker #1-1] TRACE 16:57:37.817 at org.jboss.netty.handler.codec.http.HttpHeaders.setHeader(HttpHeaders.java:862)
    [New I/O server worker #1-1] TRACE 16:57:37.817 at org.jboss.netty.handler.codec.http.DefaultHttpMessage.setHeader(DefaultHttpMessage.java:53)
    [New I/O server worker #1-1] TRACE 16:57:37.817 at net.pms.network.RequestV2.answer(RequestV2.java:199)
    [New I/O server worker #1-1] TRACE 16:57:37.818 at net.pms.network.RequestHandlerV2.writeResponse(RequestHandlerV2.java:206)
    [New I/O server worker #1-1] TRACE 16:57:37.818 at net.pms.network.RequestHandlerV2.messageReceived(RequestHandlerV2.java:179)
    [New I/O server worker #1-1] TRACE 16:57:37.818 at org.jboss.netty.handler.stream.ChunkedWriteHandler.handleUpstream(ChunkedWriteHandler.java:144)
    [New I/O server worker #1-1] TRACE 16:57:37.818 at org.jboss.netty.handler.codec.http.HttpChunkAggregator.messageReceived(HttpChunkAggregator.java:11
    6)
    [New I/O server worker #1-1] TRACE 16:57:37.818 at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:302)
    [New I/O server worker #1-1] TRACE 16:57:37.818 at org.jboss.netty.handler.codec.replay.ReplayingDecoder.unfoldAndfireMessageReceived(ReplayingDecode
    r.java:523)
    [New I/O server worker #1-1] TRACE 16:57:37.819 at org.jboss.netty.handler.codec.replay.ReplayingDecoder.callDecode(ReplayingDecoder.java:507)
    [New I/O server worker #1-1] TRACE 16:57:37.819 at org.jboss.netty.handler.codec.replay.ReplayingDecoder.messageReceived(ReplayingDecoder.java:444)
    [New I/O server worker #1-1] TRACE 16:57:37.819 at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:274)
    [New I/O server worker #1-1] TRACE 16:57:37.819 at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:261)
    [New I/O server worker #1-1] TRACE 16:57:37.819 at org.jboss.netty.channel.socket.nio.NioWorker.read(NioWorker.java:350)
    [New I/O server worker #1-1] TRACE 16:57:37.819 at org.jboss.netty.channel.socket.nio.NioWorker.processSelectedKeys(NioWorker.java:281)
    [New I/O server worker #1-1] TRACE 16:57:37.819 at org.jboss.netty.channel.socket.nio.NioWorker.run(NioWorker.java:201)
    [New I/O server worker #1-1] TRACE 16:57:37.820 at org.jboss.netty.util.internal.IoWorkerRunnable.run(IoWorkerRunnable.java:46)
    [New I/O server worker #1-1] TRACE 16:57:37.820 at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
    [New I/O server worker #1-1] TRACE 16:57:37.820 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
    [New I/O server worker #1-1] TRACE 16:57:37.820 at java.lang.Thread.run(Thread.java:619)
    [Thread-777] INFO 16:57:37.930 Stopping Unix process 71107: ffmpeg

    Some info about the movie (from mediainfo)
    Video
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : High@L3.1
    Format settings, CABAC : Yes
    Format settings, ReFrames : 3 frames
    Muxing mode : Container profile=Unknown@3.1
    Codec ID : V_MPEG4/ISO/AVC
    Duration : 49mn 32s
    Bit rate : 2 633 Kbps
    Nominal bit rate : 2 767 Kbps
    Width : 1 280 pixels
    Height : 720 pixels
    Display aspect ratio : 16/9
    Frame rate : 23.976 fps
    Resolution : 24 bits
    Colorimetry : 4:2:0
    Scan type : Progressive

    Audio
    Format : AC-3
    Format/Info : Audio Coding 3
    Codec ID : A_AC3
    Duration : 49mn 35s
    Bit rate mode : Constant
    Bit rate : 384 Kbps
    Channel(s) : 2 channels

  29. Recently, all subtitles have stopped working for me. I have changed no configuration settings with any codecs or with PS3 Media Server. The only thing i can think that has changed was there was a recent JAVA update. I’m not really sure what else it could be. Anyone else having this issue? If not, I have no idea why it stopped working… I fooled around with it for a while but to no avail. =/

  30. Read this http://www.ps3mediaserver.org/forum/viewtopic.php?f=6&t=10115 thread. It is probably something to do with that. Not sure, but sounds like it. Anyway, I’ll just wait and see if the problem fixes itself in newer versions.

    Thanks SubJunk for all your hard work! You are the best!

  31. Hi!

    I ask PMS to not transcode mkv files, and this works fine. Except that for some .mkv file, it shows them with mpeg extension, and my BDP-7500 B2 can not read them.
    I restarted PMS, and for some of them they are now displayed like normal mkv files, playing successfully.

    Strange, isn’t it?

  32. I tested older versions of ps3 media server and various subjunk builds but still subtitles are not working on all of them. I had another thought though about what could have caused it. I did recently upgrade my ps3 to the newest firmware. I’m not positive it stopped working after that but it was around that time.

  33. SubJunk

    March 26, 2011 at 4:24 pm

    @itmeMARIO: Do you have a link to one of the files that doesn’t work properly? I can try to fix it if I have a file to test

  34. @SubJunk: Hey! It seems to work now in SB20. Good stuff! Thanks for the new version 😉

  35. I’d like to thanks you for this release, for some reason it’s the ONLY version of PS3 media server which is working fine on my computer. I think i tried every version (SB or official) until V1.50, then i gave up and keep on 1.21.0-SB19, and it plays fine absolutely every files!! Sometimes for some MKV files if they cannot be played, i just have to use MKV Merge and change compression to “none” in order to make them work.

    Intel Core2 Quad q6600 4gb Ram
    Windows 7 x64

Leave a Reply

Your email address will not be published.

*

© 2021 Spirton

Theme by Anders NorenUp ↑